* had to upgrade kernel to get badblocks to pass for virtio-stor (for small swap partition)
* scsi emulation seems unstable - puts kvm in unusable state after days of use... only fix is to stop, start vm (clicking "reset" doesn't fix)
* virtio fails for partitions >1 TB (mkfs.ext2 verifies this quickly):
 - http://sourceforge.net/tracker/?func=detail&atid=893831&aid=2933400&group_id=180599
 - http://marc.info/?l=qemu-devel&m=127436114712437
 - http://bugs.gentoo.org/show_bug.cgi?id=321005
 - https://bugs.launchpad.net/ubuntu/+source/qemu-kvm/+bug/574665
 - http://git.savannah.gnu.org/cgit/qemu.git/commit/?id=77be4366baface6613cfc312ba281f8e5860997c
 - http://git.kernel.org/?p=virt/kvm/qemu-kvm.git;a=commit;h=77be4366baface6613cfc312ba281f8e5860997c
 - put patch in pve-qemu-kvm_2010-05-25/debian/patches
 - grab, install etherboot from squeeze
 - add filename you created to pve-qemu-kvm_2010-05-25/debian/patches/series
 - sudo aptitude install git-core build-essential debhelper autotools-dev  libpci-dev quilt etherboot lintian fakeroot
 - sudo apt-get build-dep kvm

binaries: http://download.proxmox.com/debian/
source: http://download.proxmox.com/sources/


upgraded to same repo as kernel:
acpi-support-base
acpid

Package: acpi-support-base
Pin: release a=testing
Pin-Priority: 999

Package: acpid
Pin: release a=testing
Pin-Priority: 999
computer/rebuilding_kvm_to_fix_viostor.txt · Last modified: 2011/03/05 20:04 by tdobes
Recent changes RSS feed Driven by DokuWiki Valid XHTML 1.0 Valid CSS